User Interface

View Control

Cell Editor has several functions available to control the view of the current workcell. Changing the view while working in Cell Editor allows greater control over the actions being performed.

cursor Left-Click and Drag: Rotates the view about the currently selected body, link or joint.

Right-Click and Drag: Pans the view.

Scroll Wheel: Zooms the view in and out.

cube View Cube: The view cube located in the top right can be used to quickly set the view orientation and the zoom scale to center on the selected body. To use this tool, select the body, link or joint currently being worked on and click on the intended side of the view cube.

Selecting Multiple Elements

Clicking an element in the 3D viewer selects it, replacing the current selection. Multiple elements can be selected at once using the following:

  • Shift + Click: Adds the clicked element to the current selection.

  • Shift + Click and Drag: Draws a selection box, adding all elements inside the box to the current selection.

  • Ctrl + Click: Toggles whether the clicked element is selected.

  • Alt + Click: Removes the clicked element from the current selection.

The type of elements that are selected depends on the current selection mode.

Docks and Toolbars

Within Verbotics Cell Editor, windows, ribbons and toolbars are scalable modular elements within the user-interface. Windows can moved or reordered by dragging the window title. Windows can be popped-out by dragging the window or by clicking the pop-out pop icon next to the close panel button cross.

After making changes to the user-interface, docks and toolbars can be reset to the default configuration. To do this, navigate to the View menu in the top ribbon. Select Reset Layout.

Right clicking on the header of any docks on the right side of the application will open a context menu for enabling and disabling different widgets in the viewer.

Ribbon

The ribbon along the top of the application provides quick access to the most common actions, grouped by purpose.

ribbon

The Cell Editor Ribbon

Import:

  • Import Preset: Imports a component preset, such as a robot, positioner or tool, from the preset library into the current workcell.

  • Import STEP: Imports one or more CAD .STEP files into the workcell. This is useful when importing manufacturer CAD files to create elements in the Cell Editor environment. To learn more, see STEP Import Tool.

Clipboard:

  • Paste: Pastes the elements on the clipboard into the currently selected location.

  • Cut, Copy and Duplicate: Cuts or copies the selected elements to the clipboard, or duplicates them in place.

View:

  • Show All: Makes all hidden items in the workcell visible again.

Configuration:

  • Problems: Shows the number of problems and suggestions found in the workcell. Click to view the details of each problem. When there are none, this shows No Problems.

  • Model: Opens the workcell or preset configuration. See Model Configuration for more detail.

  • Validators: Adds additional validation rules for the workcell.

Export:

  • Publish: Publishes the workcell to the accounts portal so other users can access it. This shows Publish New for a workcell that has not been published before, and Publish Update for one that has. This requires the appropriate license entitlement. See Managing Workcells for more detail.

  • Send to Weld: Installs the workcell to the Verbotics Weld library and opens it in Weld, allowing workcells to be tested while being edited.

Creating, opening and saving workcells is done through the File menu. See Managing Workcells for more detail.

Manipulation Tools

linear Linear Transform: Selecting linear transform allows elements or origins to be transformed along a single axis at a time.

rotate Angular Transform: Selecting angular transform allows elements or origins to be rotated about its origin.

planar Planar Transform: Selecting planar transform allows elements or origins to be transformed along two axis concurrently.

snap Snap Distance: When toggled, snap distance is the defined position change when transforming by dragging. For example, a snap distance of 1mm only allows a position changes of 1mm allowing positions of 0mm, 1mm, 2mm etc.

snap Snap Angle: When toggled, snap angle is the defined angular change when transforming by dragging. For example, a snap angle of 45° only allows an angle change of 45° allowing angles of 0°, 45°, 90° etc.

Selection Tools

The selection tools set the type of element that is selected when clicking in the 3D viewer. Each selection mode also has a keyboard shortcut.

select-all Select Components (C): Selects entire components, such as robots, tools and work stations.

select-link Select Links (L): Selects links, the connections between joints.

select-joint Select Joints (J): Selects joints, which position links.

select-body Select Bodies (B): Selects bodies, the visual or collision information attached to a link.

select-vertices Select Mesh Vertices (V): Selects the individual points of a body. Use cases include selecting sections of a single body for collision creation, or to extract positions.

Visual Tools

show-collision Show Collision: Selecting show collision toggles the visual representation of collision bodies and meshes.

show-visual Show Visual: Selecting show visual toggles the visual bodies and meshes.

show-kinematics Show Kinematics: Selecting show kinematics toggles the kinematics view of joints and links.

show-grid Show Grid: Selecting show grid enables a visual 2D grid along the x-y plane at z=0.

Creation Tools

Components

The Create button at the top of the Components panel provides actions for adding components to the workcell:

import-preset Import Preset…: Imports a component preset from the preset library.

create-from-template Create from Template…: Opens the preset library filtered to templates, which can be used as a starting point for a new component.

select-all Create from Selection…: Creates a new component, such as a robot, positioner, tool, work station, vision sensor or ancillary, from an existing group in the workcell.

Elements

The Add button at the top of the World panel adds new elements to the currently selected element in the world tree:

add-link Add a Link: Adds an empty link to the currently selected parent joint. Note that in URDF links cannot be added to other parent links and must be attached to a parent joint.

add-joint Add a Joint: Adds an empty joint to the currently selected parent link. Note that in URDF joints cannot be added to other parent joints and must be attached to a parent link.

add-body Add a Body: Adds a visual or collision body, with preset shapes available to define the physical parameters.

add-group Add a Group: Adds a new group comprising of the selected joints.

add-state Add a Group State: Adds a new state to the current group, based on the positions in the Jog panel.

add-mimic Add Joint Mimic: Adds a joint mimic, which controls the position of a joint based on other joints.

add-calibration Add a Cell Calibration: Adds a cell calibration element, used to apply calibration points measured on a physical cell.

add-measurement Add a Calibration Measurement: Adds a measurement to a cell calibration, representing a single point measured on the physical cell.

See Cell Elements for more detail on each element.

Panels

Components: Lists the components that make up the workcell, such as robots, positioners, tools and work stations. Components can be searched for, shown or hidden, and created using the Create button. To learn more, see Components Tree.

World: The world tree manages the hierarchy of links, joints, bodies and other elements in the current workcell. To learn more, see World Tree.

Presets: The preset library is a quick and accessible way to build workcells from existing presets. Presets can be searched for and filtered, and are stored in the preset library directory set in Edit > Preferences > General.

Properties: Shows the configuration and properties of the currently selected element.

Component Configuration: Shows the configuration of the currently selected component. To learn more, see Component Configuration.

Manipulation: Tracks and allows the fine adjustment of the translation and rotation of links, joints, and bodies. This tool allows the global and local positioning of elements.

Jog: Allows movement of revolute and prismatic joints, either individually or as grouped by joint groups.

Collision Checker: Shows collisions between elements in the workcell, and allows collisions between pairs of links to be disabled. To learn more, see Collisions.